Samba ne démarre pas avec systemd

Sep 05 2020

J'installe samba 4.12.6 à partir des sources sur centos 8.

Quand je commence la samba directement

/usr/local/samba/sbin/samba

il fonctionne es attendu.

Maintenant, je crée une unité systemd:

[Unit]
Description=Samba Active Directory Domain Controller
After=network.target

[Service]
Type=forking
ExecStart=/usr/local/samba/sbin/samba -D
PIDFile=/usr/local/samba/var/run/samba.pid
ExecReload=/bin/kill -HUP $MAINPID

[Install]
WantedBy=default.target

Démarrez-le et il échoue avec l'autorisation refusée

[root@centos-server-01 ~]# systemctl status samba-ad.service
● samba-ad.service - Samba Active Directory Domain Controller
   Loaded: loaded (/etc/systemd/system/samba-ad.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2020-09-04 19:03:24 CEST; 14s ago
  Process: 1549 ExecStart=/usr/local/samba/sbin/samba -D (code=exited, status=203/EXEC)

Sep 04 19:03:24 centos-server-01 systemd[1]: Starting Samba Active Directory Domain Controller...
Sep 04 19:03:24 centos-server-01 systemd[1]: samba-ad.service: Control process exited, code=exited status=203
Sep 04 19:03:24 centos-server-01 systemd[1]: samba-ad.service: Failed with result 'exit-code'.
Sep 04 19:03:24 centos-server-01 systemd[1]: Failed to start Samba Active Directory Domain Controller.

journalctl spectacles:

journalctl _PID=1549
-- Logs begin at Fri 2020-09-04 18:00:19 CEST, end at Fri 2020-09-04 19:03:39 CEST. --
Sep 04 19:03:24 centos-server-01 systemd[1549]: samba-ad.service: Failed to execute command: Permission denied
Sep 04 19:03:24 centos-server-01 systemd[1549]: samba-ad.service: Failed at step EXEC spawning /usr/local/samba/sbin/samba: Permission denied

Le binaire samba est exécutable:

ls -al /usr/local/samba/sbin/
total 2816
-rwxr-xr-x.  1 root root  771608 Sep  2 17:28 eventlogadm
-rwxr-xr-x.  1 root root  331304 Sep  2 17:28 nmbd
-rwxr-xr-x.  1 root root   58280 Sep  2 17:27 samba
-rwxr-xr-x.  1 root root    3616 Sep  1 20:15 samba-gpupdate
.
.

file spectacles:

/usr/local/samba/sbin/samba: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically li    nked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.2.0, BuildID[sha1]=3f9ee20e102f467fc    12e1b4bc913472f23dcde0b, not stripped

Je suis toujours connecté en tant que root. J'ai lu Échec à l'étape du frai EXEC ... Autorisation refusée et ce qui suit mais cela n'a pas aidé.

Peut-être que quelqu'un a un indice pour moi

Réponses

2 kofemann Sep 05 2020 at 19:30

Le SELinux limite les binaires qui peuvent être utilisés dans ExecStart aux chemins dont l' system_u:object_r:bin_t:s0attribut est défini. Ce sont généralement des /usr/bin /usr/sbin /usr/libexec /usr/local/binrépertoires. Vous devez déplacer le binaire samba dans l'un de ces répertoires ou modifier la politique de selinux pour permettre à systemd d'utiliser des binaires dans / usr / local / samba / sbin / comme:

chcon -R -t bin_t /usr/local/samba/sbin/