không thể bắt đầu mysqld

Aug 24 2020

Tôi nhận được những điều sau khi tôi cố gắng khởi động mysql:

$ sudo systemctl start mysqld Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details. [pi@raspi ~]$ systemctl status mysqld
* mariadb.service - MariaDB 10.5.5 database server
     Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sun 2020-08-23 08:34:44 PDT; 9s ago
       Docs: man:mariadbd(8)
             https://mariadb.com/kb/en/library/systemd/
    Process: 466 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
    Process: 467 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`cd /usr/bin/..; /usr/bin/galera_recovery`; [ $? -eq 0 ] && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/S>
    Process: 479 ExecStart=/usr/bin/mariadbd $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=1/FAILURE)
   Main PID: 479 (code=exited, status=1/FAILURE)
     Status: "MariaDB server is down"

Aug 23 08:34:44 raspi mariadbd[479]: 2020-08-23  8:34:44 0 [ERROR] InnoDB: Upgrade after a crash is not supported. The redo log was created with MariaDB 10.4.14.
Aug 23 08:34:44 raspi mariadbd[479]: 2020-08-23  8:34:44 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
Aug 23 08:34:44 raspi mariadbd[479]: 2020-08-23  8:34:44 0 [Note] InnoDB: Starting shutdown...
Aug 23 08:34:44 raspi mariadbd[479]: 2020-08-23  8:34:44 0 [ERROR] Plugin 'InnoDB' init function returned error.
Aug 23 08:34:44 raspi mariadbd[479]: 2020-08-23  8:34:44 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
Aug 23 08:34:44 raspi mariadbd[479]: 2020-08-23  8:34:44 0 [ERROR] Unknown/unsupported storage engine: InnoDB
Aug 23 08:34:44 raspi mariadbd[479]: 2020-08-23  8:34:44 0 [ERROR] Aborting
Aug 23 08:34:44 raspi systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
Aug 23 08:34:44 raspi systemd[1]: mariadb.service: Failed with result 'exit-code'.
Aug 23 08:34:44 raspi systemd[1]: Failed to start MariaDB 10.5.5 database server.
lines 1-21/21 (END)

Tôi không thấy bất kỳ thông tin từ syslog-ngtrong /var/log/messages.logmột trong hai ....

Tôi không chắc chuyện gì đang xảy ra, ai đó có thể giúp tôi với điều này được không? : o

Như @tetech đã đề xuất, tôi nên hạ cấp xuống phiên bản trước của gói mariadb của mình. Vì vậy, tôi đã thử:

[pi@raspi pkg]$ sudo pacman -U /var/cache/pacman/pkg/mariadb-10.4.14-1-aarch64.pkg.tar.xz 
[sudo] password for pi: 
loading packages...
warning: downgrading package mariadb (10.5.5-1 => 10.4.14-1)
resolving dependencies...
warning: cannot resolve "mariadb-clients=10.4.14", a dependency of "mariadb"
:: The following package cannot be upgraded due to unresolvable dependencies:
      mariadb

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'mariadb-clients=10.4.14' required by mariadb
[pi@raspi pkg]$ sudo pacman -U /var/cache/pacman/pkg/mariadb-clients-10.4.14-1-aarch64.pkg.tar.xz loading packages... warning: downgrading package mariadb-clients (10.5.5-1 => 10.4.14-1) resolving dependencies... warning: cannot resolve "mariadb-libs=10.4.14", a dependency of "mariadb-clients" :: The following package cannot be upgraded due to unresolvable dependencies: mariadb-clients :: Do you want to skip the above package for this upgrade? [y/N] error: failed to prepare transaction (could not satisfy dependencies) :: unable to satisfy dependency 'mariadb-libs=10.4.14' required by mariadb-clients [pi@raspi pkg]$ sudo pacman -U /var/cache/pacman/pkg/mariadb-libs-10.4.14-1-aarch64.pkg.tar.xz    
loading packages...
warning: downgrading package mariadb-libs (10.5.5-1 => 10.4.14-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing mariadb-libs (10.4.14-1) breaks dependency 'mariadb-libs=10.5.5' required by mariadb-clients
[pi@raspi pkg]$ sudo pacman -U /var/cache/pacman/pkg/mariadb-clients-10.4.14-1-aarch64.pkg.tar.xz 
loading packages...
warning: downgrading package mariadb-clients (10.5.5-1 => 10.4.14-1)
resolving dependencies...
warning: cannot resolve "mariadb-libs=10.4.14", a dependency of "mariadb-clients"
:: The following package cannot be upgraded due to unresolvable dependencies:
      mariadb-clients

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'mariadb-libs=10.4.14' required by mariadb-clients

Nhưng có vẻ như mariadb-libslà phàn nàn về mariadb-clientsvà ngược lại. Làm cách nào để tôi bị hạ cấp? Bây giờ tôi đang nghĩ rằng nó có thể dễ dàng hơn để cài đặt lại db của tôi thay thế ....

Trả lời

1 tater Aug 23 2020 at 22:52

Lỗi đáng chú ý là InnoDB: Upgrade after a crash is not supported. The redo log was created with MariaDB 10.4.14.

Có vẻ như bạn đã không dừng DB đúng cách và sau đó nâng cấp nó.

Bạn sẽ cần hạ cấp xuống 10.4.14 và thực hiện khôi phục hoặc khởi tạo lại hoặc sau đó khôi phục bản sao lưu bạn đã thực hiện trước khi nâng cấp.

1 Dr-Bracket Aug 26 2020 at 22:54

Giải pháp của tôi trên Manjaro Linux là sudo pacman -s downgradesau đó chạy

downgrade mariadb-libs mariadb-clients mariadb

Hạ cấp cho phép bạn chọn phiên bản để hạ cấp xuống. Siêu dễ dàng, làm việc như một sự quyến rũ.

BitFreak Aug 25 2020 at 03:29

Giải pháp để hạ cấp máy chủ mysql là:

$ sudo pacman -U /var/cache/pacman/pkg/mariadb-clients-10.4.14-1-aarch64.pkg.tar.xz /var/cache/pacman/pkg/mariadb-libs-10.4.14-1-aarch64.pkg.tar.xz /var/cache/pacman/pkg/mariadb-10.4.14-1-aarch64.pkg.tar.xz

sau đó, tôi đã có thể khởi động lại máy chủ MySql của mình tốt và tôi phải xem xét cách nâng cấp nó ngay bây giờ.